Unix & Linux
linux-mint drivers nvidia
Updated Sat, 02 Jul 2022 02:01:50 GMT

Nvidia driver 418 missing dependencies


I was following this guide: https://github.com/lutris/lutris/wiki/Installing-drivers and when I tried to install the driver, it throwed this error:

The following packages have unmet dependencies:
 nvidia-driver-418 : Depends: xserver-xorg-video-nvidia-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-cfg1-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have tried fixing it using multiple different ways:

  • I tried to install it using -f, it throws same output regardless
  • I updated and upgraded aptitude
  • sudo apt-get clean, output is empty
  • sudo dpkg --configure -a, output is empty
  • sudo apt-get -f install, output is this:

    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  • sudo apt-get build-dep build-essential but that throws an error:

    E: Unable to find a source package for build-essential

What am I supposed to do? I am using Linux Mint 19.1 and I have GTX 1060 graphics card.




Solution

Removing my old nvidia driver with the command

sudo apt-get purge nvidia*

before installing the new driver fixed the problem. I would have hoped that the Lutris guide would have said anything about removing old nvidia driver first, but I guess that it should be common sense.







External Links

External links referenced by this document: